Search

Forum

Please or Registrovat to create posts and topics.

Problems with RPN 42s calculator

Good evening,

As the headline suggest, I'm here to talk about a problem with my RPN 42s calculator.

After several months, the calculator's batteries have run out of energy and the calculator suddenly turned off. So after changing the batteries, I tried to turn it on but it doesn't work, so as suggested on the manual, I have tried to use a coin to short circuit the calculator. It turned on but a strange "NULL" error appeared on the display and now some functions does not respond anymore (for example if I press "x" (multiplication), it doesn't work or, if it works it displays the NULL error). I have tried to do some diagnostic (pressing EXIT and LIN) but it doesn't work either. Searching online there wasn't anything about this problem.  Now my last hope is that some wire or connection broke down and they don't work.

Thank to you all, I hope you will be able to help me

Samuele

Hi Samuele,

 

Unfortunately, we cannot offer any support on the legacy models of HP, such as the 42S. I advise you to ask your question on the Museum of HP Calcs forum.

 

Klaas.